Esp32-s2 uf2 damaged

Please tell us which board you are using.

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
User avatar
Posts: 1
Joined: Wed Nov 23, 2022 7:08 pm

Esp32-s2 uf2 damaged

Post by remagg »

Hi, i've been trying to use a metro esp32-s2. While setting it up i flashed it with uf2 and then tried flashing it with different with an arduino sketch.

On the page for installing uf2 it says that this, now damaged bootloader, can be fixed by reflashing it with uf2, but i want it to be removed. I've tried erasing the flash with the web serial tool and the esptool, but neither of them fixed the issues i have. It seems that a damaged installation of the uf2 bootloader is to blame, so can anyone help me remove it?

Below is what i've experienced and tried while trying to fix the issue.
Since flashing the board with uf2 and any new firmware, the device doesn't show up as a com device and only as a portable device with a drive.

When flashing any new firmware like blink the device won't blink and only be seen as the portable device. However sometimes when the board is power cycled, it runs the flashed firmware and blinks but still doesn't show up as a com device.

Erasing the flash with the esptool or web serial tool does not fix the issue, so i'm not sure what else to try.

User avatar
Posts: 9555
Joined: Mon Aug 01, 2016 8:10 pm

Re: Esp32-s2 uf2 damaged

Post by mikeysklar »

It sounds as though the bootloader is functional if you are seeing a drive and able to upload code through the Arduino IDE.

Are there any errors when uploading the blink program. You will need to enable verbose output for compilation and upload. File --> Preferences

Please be positive and constructive with your questions and comments.

Return to “Metro and Metro Express, Grand Central”