MarOS atmega162 hex help

Discuss mods, hacks, tweaks, etc.

Moderators: altitude, adafruit_support_bill, adafruit, hamburgers, phono

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
Davidttl
 
Posts: 4
Joined: Sun Jan 08, 2023 8:00 am

MarOS atmega162 hex help

Post by Davidttl »

Hi,
my first post.

I have a very basic question - how to compile MarOS1.5 v1.82 to .hex for Atmega162 on win/linux?

In the post viewtopic.php?p=657356#p657356 the source files are provided, but no makefile.
I have tried winavr on w10 and gcc-avr on linux and have no luck getting it to work.

I am deluding myself that maybe this version of MarOS will work properly on my x0x. The software itself is interesting, it has some cool options, but in order not to get frustrated I am staying on SokkOS2 for now.

The earlier .hex files I found in the MarOS topic don't always upload correctly via soft from antto (great one btw). And if they do succeed, they have bugs that (for me) make it impossible to work - for example: pattern after editing and saving plays different notes than previously saved and octave down.

I would be grateful if someone would write how to prepare a makefile for it or post a working one.

Thanks,
Davidttl

User avatar
oer23
 
Posts: 7
Joined: Thu Dec 15, 2022 2:18 pm

Re: MarOS atmega162 hex help

Post by oer23 »

I don't understand your problem. You can't upload the .hex from MarOS on your X0x?
A friend would mod this OS, when he will make it I can ask what is he used for compile it.
For my part I upload it on the atmega 162 with a USBtiny and AVRdudess on a breadboard, and all is ok.

User avatar
Davidttl
 
Posts: 4
Joined: Sun Jan 08, 2023 8:00 am

Re: MarOS atmega162 hex help

Post by Davidttl »

Hi oer23,

as you can see on screenshot of that (latest MarOS1.5 v1.82) zip file - there's no .hex or Makefile. Earlier versions had .hex files attached and I had no problem with uploading them to x0xb0x with conbox.

I'm a c/c++ noob, that's why I have problems like this :)

Off topic - oer23, I am impressed with your modifications and skills. X0x probably do a great job playing on the walls of sound systems.
Attachments
Screenshot_20230112_085352.png
Screenshot_20230112_085352.png (142.31 KiB) Viewed 135 times

User avatar
oer23
 
Posts: 7
Joined: Thu Dec 15, 2022 2:18 pm

Re: MarOS atmega162 hex help

Post by oer23 »

You just have to go to the first page of the topic to get the ".hex": viewtopic.php?t=33914
Davidttl wrote: Thu Jan 12, 2023 4:18 am Off topic - oer23, I am impressed with your modifications and skills. X0x probably do a great job playing on the walls of sound systems.
Thanks I just "stolen" mods from internet and bcbox (his real name is banned, WTF?) work, my "only" job was to make/modify the PCBs.
But yes, this X0x have a very good sound now, much as a standard synth than a basic bassline.

User avatar
Davidttl
 
Posts: 4
Joined: Sun Jan 08, 2023 8:00 am

Re: MarOS atmega162 hex help

Post by Davidttl »

It's not the 'latest' version.
I tried the .hex from the first page, and I also tried the later ones that appear on the following pages of this topic (every one for Atmega162 what had .hex attached).

My x0x only partially worked well with MarOS. I had problems with saving patterns - after saving they were in the wrong octave and often with different notes.
So it could be a problem with my machine - when connected with a DAW or other synth - it plays in the wrong octave - always lower by 12-24 semitones(this is for Reaper and Renoise).
When I sent midi from x0x to td-3, td-3 played an octave higher than x0x. And when td-3 sent midi to x0x - x0x played an octave lower.
And it was like that since I owned it. I just don't know where to look - is it a problem on the firmware or hardware side.

My x0x is modified as per the subatomic page. No ENV/Gate on forever and simplified muffler distortion.
One noticeable thing I have a problem with - is the level of accented notes. There is too much difference in decibels (up to 16dB) between a normal note and one with an accent. Accent catches only from 75% of the potentiometer position.
Do you have a similar problem? Or am I the lucky one ;)

BANNED - this is some kind of filter on the forum, which automatically turns some words into BANNED

User avatar
oer23
 
Posts: 7
Joined: Thu Dec 15, 2022 2:18 pm

Re: MarOS atmega162 hex help

Post by oer23 »

I can't answer for your problem.
I use the MarOS of the first page, but I don't notice your bugs: I have the good notes and the good octave and I don't ear some trouble with my accent.
But I didn't use it extensively, I didn't make a lot of music this time, I use my time to modify and build some electronic instruments, so my advise about these bugs is not necessarily very good, sorry.

User avatar
Davidttl
 
Posts: 4
Joined: Sun Jan 08, 2023 8:00 am

Re: MarOS atmega162 hex help

Post by Davidttl »

oer23 wrote: Thu Jan 12, 2023 3:55 pm I can't answer for your problem.
I use the MarOS of the first page, but I don't notice your bugs: I have the good notes and the good octave
You actually helped me understand that it might not be a firmware problem, since you have not had such problems (and probably no one else has).

Post Reply
Please be positive and constructive with your questions and comments.

Return to “x0xm0dz”