braincraft hat. Error when testing hat microphone

Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Thank you, Melissa. With a 2GB pi the Bullseye desktop version may be too bogged down. I'll wait for your tests with Lite

User avatar
MakerMelissa
 
Posts: 334
Joined: Wed Jun 05, 2013 2:10 am

Re: braincraft hat. Error when testing hat microphone

Post by MakerMelissa »

It worked fine in both Desktop and Lite for me. After looking at your output, I think maybe you had a bad install of the sound module. Perhaps it had trouble grabbing something from the internet. Here's the output from mine which worked, so you can see how it's different:

Code: Select all

sudo ./install.sh
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
git is already the newest version (1:2.30.2-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Cloning into 'seeed-voicecard'...
remote: Enumerating objects: 1363, done.
remote: Counting objects: 100% (387/387), done.
remote: Compressing objects: 100% (30/30), done.
remote: Total 1363 (delta 365), reused 367 (delta 357), pack-reused 976
Receiving objects: 100% (1363/1363), 1.16 MiB | 2.64 MiB/s, done.
Resolving deltas: 100% (897/897), done.
Hit:1 http://security.debian.org/debian-security bullseye-security InRelease
Hit:2 http://deb.debian.org/debian bullseye InRelease
Hit:3 http://deb.debian.org/debian bullseye-updates InRelease
Hit:4 http://archive.raspberrypi.org/debian bullseye InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
raspberrypi-kernel is already the newest version (1:1.20230106-1).
raspberrypi-kernel-headers is already the newest version (1:1.20230106-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package linux-raspi
E: Unable to locate package linux-headers-raspi
E: Unable to locate package linux-image-raspi
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
git is already the newest version (1:2.30.2-1).
i2c-tools is already the newest version (4.2-1+b1).
The following additional packages will be installed:
  dctrl-tools fontconfig libaom0 libasyncns0 libavcodec58 libavresample4 libavutil56 libcairo-gobject2 libcairo2 libcodec2-0.9 libdatrie1 libdav1d4
  libdrm-amdgpu1 libdrm-nouveau2 libdrm-radeon1 libfribidi0 libgdk-pixbuf-2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgl1 libgl1-mesa-dri
  libglapi-mesa libglvnd0 libglx-mesa0 libglx0 libgraphite2-3 libgsm1 libharfbuzz0b libjack-jackd2-0 libllvm11 libmp3lame0 libnuma1 libopus0
  libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0 libpulse0 librsvg2-2 librsvg2-common libsensors-config libsensors5 libshine3
  libsnappy1v5 libsndfile1 libsoxr0 libspeex1 libswresample3 libthai-data libthai0 libtheora0 libtwolame0 libva-drm2 libva-x11-2 libva2 libvdpau-va-gl1
  libvdpau1 libvorbisenc2 libvpx6 libvulkan1 libwavpack1 libwayland-client0 libx11-xcb1 libx264-160 libx265-192 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
  libxcb-present0 libxcb-randr0 libxcb-render0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxdamage1 libxfixes3 libxrender1 libxshmfence1 BANNED
  libxxf86vm1 libz3-4 libzvbi-common libzvbi0 mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers ocl-icd-libopencl1 shared-mime-info va-driver-all
  vdpau-driver-all
Suggested packages:
  debtags menu jackd2 opus-tools pulseaudio librsvg2-bin lm-sensors speex opencl-icd nvidia-vdpau-driver
The following NEW packages will be installed:
  dctrl-tools dkms fontconfig libaom0 libasound2-plugins libasyncns0 libavcodec58 libavresample4 libavutil56 libcairo-gobject2 libcairo2 libcodec2-0.9
  libdatrie1 libdav1d4 libdrm-amdgpu1 libdrm-nouveau2 libdrm-radeon1 libfribidi0 libgdk-pixbuf-2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgl1
  libgl1-mesa-dri libglapi-mesa libglvnd0 libglx-mesa0 libglx0 libgraphite2-3 libgsm1 libharfbuzz0b libjack-jackd2-0 libllvm11 libmp3lame0 libnuma1
  libopus0 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0 libpulse0 librsvg2-2 librsvg2-common libsensors-config libsensors5
  libshine3 libsnappy1v5 libsndfile1 libsoxr0 libspeex1 libswresample3 libthai-data libthai0 libtheora0 libtwolame0 libva-drm2 libva-x11-2 libva2
  libvdpau-va-gl1 libvdpau1 libvorbisenc2 libvpx6 libvulkan1 libwavpack1 libwayland-client0 libx11-xcb1 libx264-160 libx265-192 libxcb-dri2-0
  libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-randr0 libxcb-render0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxdamage1 libxfixes3 libxrender1
  libxshmfence1 BANNED libxxf86vm1 libz3-4 libzvbi-common libzvbi0 mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers ocl-icd-libopencl1
  shared-mime-info va-driver-all vdpau-driver-all
0 upgraded, 92 newly installed, 0 to remove and 0 not upgraded.
Need to get 62.8 MB of archives.
After this operation, 231 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian bullseye/main arm64 dctrl-tools arm64 2.24-3 [101 kB]
Get:2 http://deb.debian.org/debian bullseye/main arm64 dkms all 2.8.4-3 [78.2 kB]
Get:3 http://deb.debian.org/debian bullseye/main arm64 fontconfig arm64 2.13.1-4.2 [416 kB]
Get:4 http://deb.debian.org/debian bullseye/main arm64 libaom0 arm64 1.0.0.errata1-3 [824 kB]
Get:5 http://archive.raspberrypi.org/debian bullseye/main arm64 libavutil56 arm64 7:4.3.5-0+deb11u1+rpt3 [305 kB]
Get:6 http://deb.debian.org/debian bullseye/main arm64 libva2 arm64 2.10.0-1 [64.6 kB]
Get:7 http://deb.debian.org/debian bullseye/main arm64 libva-drm2 arm64 2.10.0-1 [19.0 kB]
Get:8 http://deb.debian.org/debian bullseye/main arm64 libxfixes3 arm64 1:5.0.3-2 [22.1 kB]
Get:9 http://deb.debian.org/debian bullseye/main arm64 libva-x11-2 arm64 2.10.0-1 [23.3 kB]
Get:10 http://deb.debian.org/debian bullseye/main arm64 libvdpau1 arm64 1.4-3 [27.1 kB]
Get:11 http://deb.debian.org/debian bullseye/main arm64 ocl-icd-libopencl1 arm64 2.2.14-2 [41.5 kB]
Get:12 http://deb.debian.org/debian bullseye/main arm64 libxcb-render0 arm64 1.14-3 [111 kB]
Get:13 http://deb.debian.org/debian bullseye/main arm64 libxcb-shm0 arm64 1.14-3 [101 kB]
Get:14 http://deb.debian.org/debian bullseye/main arm64 libxrender1 arm64 1:0.9.10-1 [30.4 kB]
Get:15 http://deb.debian.org/debian bullseye/main arm64 libcodec2-0.9 arm64 0.9.2-4 [7,879 kB]
Get:16 http://archive.raspberrypi.org/debian bullseye/main arm64 libpixman-1-0 arm64 0.40.0-1.1~deb11u1+rpt1 [446 kB]
Get:17 http://archive.raspberrypi.org/debian bullseye/main arm64 libcairo2 arm64 1.16.0-5+rpt1 [648 kB]
Get:18 http://archive.raspberrypi.org/debian bullseye/main arm64 libcairo-gobject2 arm64 1.16.0-5+rpt1 [125 kB]
Get:19 http://archive.raspberrypi.org/debian bullseye/main arm64 libswresample3 arm64 7:4.3.5-0+deb11u1+rpt3 [101 kB]
Get:20 http://archive.raspberrypi.org/debian bullseye/main arm64 libavcodec58 arm64 7:4.3.5-0+deb11u1+rpt3 [4,606 kB]
Get:21 http://archive.raspberrypi.org/debian bullseye/main arm64 libavresample4 arm64 7:4.3.5-0+deb11u1+rpt3 [94.4 kB]
Get:22 http://archive.raspberrypi.org/debian bullseye/main arm64 libpulse0 arm64 14.2-2+rpt1 [244 kB]
Get:23 http://archive.raspberrypi.org/debian bullseye/main arm64 libglapi-mesa arm64 20.3.5-1+rpt4+rpi1 [98.2 kB]
Get:24 http://archive.raspberrypi.org/debian bullseye/main arm64 libgl1-mesa-dri arm64 20.3.5-1+rpt4+rpi1 [6,557 kB]
Get:25 http://archive.raspberrypi.org/debian bullseye/main arm64 libglx-mesa0 arm64 20.3.5-1+rpt4+rpi1 [187 kB]
Get:26 http://archive.raspberrypi.org/debian bullseye/main arm64 mesa-va-drivers arm64 20.3.5-1+rpt4+rpi1 [2,405 kB]
Get:27 http://archive.raspberrypi.org/debian bullseye/main arm64 mesa-vdpau-drivers arm64 20.3.5-1+rpt4+rpi1 [2,514 kB]
Get:28 http://archive.raspberrypi.org/debian bullseye/main arm64 mesa-vulkan-drivers arm64 20.3.5-1+rpt4+rpi1 [2,691 kB]
Get:29 http://deb.debian.org/debian bullseye/main arm64 libdav1d4 arm64 0.7.1-3 [256 kB]
Get:30 http://deb.debian.org/debian bullseye/main arm64 libgsm1 arm64 1.0.18-2 [27.6 kB]
Get:31 http://deb.debian.org/debian bullseye/main arm64 libmp3lame0 arm64 3.100-3 [356 kB]
Get:32 http://deb.debian.org/debian bullseye/main arm64 libopus0 arm64 1.3.1-0.1 [169 kB]
Get:33 http://deb.debian.org/debian bullseye/main arm64 libgdk-pixbuf2.0-common all 2.42.2+dfsg-1+deb11u1 [320 kB]
Get:34 http://deb.debian.org/debian bullseye/main arm64 shared-mime-info arm64 2.0-1 [700 kB]
Get:35 http://deb.debian.org/debian bullseye/main arm64 libgdk-pixbuf-2.0-0 arm64 2.42.2+dfsg-1+deb11u1 [136 kB]
Get:36 http://deb.debian.org/debian bullseye/main arm64 libfribidi0 arm64 1.0.8-2+deb11u1 [64.9 kB]
Get:37 http://deb.debian.org/debian bullseye/main arm64 libgraphite2-3 arm64 1.3.14-1 [75.6 kB]
Get:38 http://deb.debian.org/debian bullseye/main arm64 libharfbuzz0b arm64 2.7.4-1 [1,445 kB]
Get:39 http://deb.debian.org/debian bullseye/main arm64 libthai-data all 0.1.28-3 [170 kB]
Get:40 http://deb.debian.org/debian bullseye/main arm64 libdatrie1 arm64 0.2.13-1 [42.1 kB]
Get:41 http://deb.debian.org/debian bullseye/main arm64 libthai0 arm64 0.1.28-3 [53.0 kB]
Get:42 http://deb.debian.org/debian bullseye/main arm64 libpango-1.0-0 arm64 1.46.2-3 [183 kB]
Get:43 http://deb.debian.org/debian bullseye/main arm64 libpangoft2-1.0-0 arm64 1.46.2-3 [59.4 kB]
Get:44 http://deb.debian.org/debian bullseye/main arm64 libpangocairo-1.0-0 arm64 1.46.2-3 [48.6 kB]
Get:45 http://deb.debian.org/debian bullseye/main arm64 librsvg2-2 arm64 2.50.3+dfsg-1 [2,133 kB]
Get:46 http://deb.debian.org/debian bullseye/main arm64 libshine3 arm64 3.1.1-2 [23.0 kB]
Get:47 http://deb.debian.org/debian bullseye/main arm64 libsnappy1v5 arm64 1.1.8-1 [17.2 kB]
Get:48 http://deb.debian.org/debian bullseye/main arm64 libspeex1 arm64 1.2~rc1.2-1.1 [48.9 kB]
Get:49 http://deb.debian.org/debian bullseye/main arm64 libsoxr0 arm64 0.1.3-4 [54.4 kB]
Get:50 http://deb.debian.org/debian bullseye/main arm64 libtheora0 arm64 1.1.1+dfsg.1-15 [161 kB]
Get:51 http://deb.debian.org/debian bullseye/main arm64 libtwolame0 arm64 0.4.0-2 [48.5 kB]
Get:52 http://deb.debian.org/debian bullseye/main arm64 libvorbisenc2 arm64 1.3.7-1 [80.4 kB]
Get:53 http://deb.debian.org/debian bullseye/main arm64 libvpx6 arm64 1.9.0-1 [751 kB]
Get:54 http://deb.debian.org/debian bullseye/main arm64 libwavpack1 arm64 5.4.0-1 [79.0 kB]
Get:55 http://deb.debian.org/debian bullseye/main arm64 libx264-160 arm64 2:0.160.3011+gitcde9a93-2.1 [443 kB]
Get:56 http://deb.debian.org/debian bullseye/main arm64 libnuma1 arm64 2.0.12-1+b1 [25.8 kB]
Get:57 http://deb.debian.org/debian bullseye/main arm64 libx265-192 arm64 3.4-2 [584 kB]
Get:58 http://deb.debian.org/debian bullseye/main arm64 BANNED arm64 2:1.3.7-1 [202 kB]
Get:59 http://deb.debian.org/debian bullseye/main arm64 libzvbi-common all 0.2.35-18 [64.6 kB]
Get:60 http://deb.debian.org/debian bullseye/main arm64 libzvbi0 arm64 0.2.35-18 [256 kB]
Get:61 http://deb.debian.org/debian bullseye/main arm64 libjack-jackd2-0 arm64 1.9.17~dfsg-1 [271 kB]
Get:62 http://deb.debian.org/debian bullseye/main arm64 libasyncns0 arm64 0.8-6+b2 [12.5 kB]
Get:63 http://deb.debian.org/debian bullseye/main arm64 libsndfile1 arm64 1.0.31-2 [179 kB]
Get:64 http://deb.debian.org/debian bullseye/main arm64 libasound2-plugins arm64 1.2.2-2 [72.8 kB]
Get:65 http://deb.debian.org/debian bullseye/main arm64 libdrm-amdgpu1 arm64 2.4.104-1 [28.0 kB]
Get:66 http://deb.debian.org/debian bullseye/main arm64 libdrm-nouveau2 arm64 2.4.104-1 [26.1 kB]
Get:67 http://deb.debian.org/debian bullseye/main arm64 libdrm-radeon1 arm64 2.4.104-1 [29.3 kB]
Get:68 http://deb.debian.org/debian bullseye/main arm64 libgdk-pixbuf2.0-bin arm64 2.42.2+dfsg-1+deb11u1 [25.6 kB]
Get:69 http://deb.debian.org/debian bullseye/main arm64 libz3-4 arm64 4.8.10-1 [6,117 kB]
Get:70 http://deb.debian.org/debian bullseye/main arm64 libllvm11 arm64 1:11.0.1-2 [14.7 MB]
Get:71 http://deb.debian.org/debian bullseye/main arm64 libsensors-config all 1:3.6.0-7 [32.3 kB]
Get:72 http://deb.debian.org/debian bullseye/main arm64 libsensors5 arm64 1:3.6.0-7 [51.2 kB]
Get:73 http://deb.debian.org/debian bullseye/main arm64 libvulkan1 arm64 1.2.162.0-1 [95.7 kB]
Get:74 http://deb.debian.org/debian bullseye/main arm64 libwayland-client0 arm64 1.18.0-2~exp1.1 [26.5 kB]
Get:75 http://deb.debian.org/debian bullseye/main arm64 libglvnd0 arm64 1.3.2-1 [44.3 kB]
Get:76 http://deb.debian.org/debian bullseye/main arm64 libx11-xcb1 arm64 2:1.7.2-1 [203 kB]
Get:77 http://deb.debian.org/debian bullseye/main arm64 libxcb-dri2-0 arm64 1.14-3 [103 kB]
Get:78 http://deb.debian.org/debian bullseye/main arm64 libxcb-dri3-0 arm64 1.14-3 [102 kB]
Get:79 http://deb.debian.org/debian bullseye/main arm64 libxcb-glx0 arm64 1.14-3 [118 kB]
Get:80 http://deb.debian.org/debian bullseye/main arm64 libxcb-present0 arm64 1.14-3 [101 kB]
Get:81 http://deb.debian.org/debian bullseye/main arm64 libxcb-sync1 arm64 1.14-3 [105 kB]
Get:82 http://deb.debian.org/debian bullseye/main arm64 libxcb-xfixes0 arm64 1.14-3 [105 kB]
Get:83 http://deb.debian.org/debian bullseye/main arm64 libxdamage1 arm64 1:1.1.5-2 [15.7 kB]
Get:84 http://deb.debian.org/debian bullseye/main arm64 libxshmfence1 arm64 1.3-1 [8,712 B]
Get:85 http://deb.debian.org/debian bullseye/main arm64 libxxf86vm1 arm64 1:1.1.4-1+b2 [20.1 kB]
Get:86 http://deb.debian.org/debian bullseye/main arm64 librsvg2-common arm64 2.50.3+dfsg-1 [30.8 kB]
Get:87 http://deb.debian.org/debian bullseye/main arm64 libglx0 arm64 1.3.2-1 [32.0 kB]
Get:88 http://deb.debian.org/debian bullseye/main arm64 libgl1 arm64 1.3.2-1 [91.4 kB]
Get:89 http://deb.debian.org/debian bullseye/main arm64 libvdpau-va-gl1 arm64 0.4.2-1+b1 [66.7 kB]
Get:90 http://deb.debian.org/debian bullseye/main arm64 libxcb-randr0 arm64 1.14-3 [113 kB]
Get:91 http://deb.debian.org/debian bullseye/main arm64 va-driver-all arm64 2.10.0-1 [15.3 kB]
Get:92 http://deb.debian.org/debian bullseye/main arm64 vdpau-driver-all arm64 1.4-3 [8,504 B]
Fetched 62.8 MB in 23s (2,692 kB/s)
Extracting templates from packages: 100%
Selecting previously unselected package dctrl-tools.
(Reading database ... 61031 files and directories currently installed.)
Preparing to unpack .../00-dctrl-tools_2.24-3_arm64.deb ...
Unpacking dctrl-tools (2.24-3) ...
Selecting previously unselected package dkms.
Preparing to unpack .../01-dkms_2.8.4-3_all.deb ...
Unpacking dkms (2.8.4-3) ...
Selecting previously unselected package fontconfig.
Preparing to unpack .../02-fontconfig_2.13.1-4.2_arm64.deb ...
Unpacking fontconfig (2.13.1-4.2) ...
Selecting previously unselected package libaom0:arm64.
Preparing to unpack .../03-libaom0_1.0.0.errata1-3_arm64.deb ...
Unpacking libaom0:arm64 (1.0.0.errata1-3) ...
Selecting previously unselected package libva2:arm64.
Preparing to unpack .../04-libva2_2.10.0-1_arm64.deb ...
Unpacking libva2:arm64 (2.10.0-1) ...
Selecting previously unselected package libva-drm2:arm64.
Preparing to unpack .../05-libva-drm2_2.10.0-1_arm64.deb ...
Unpacking libva-drm2:arm64 (2.10.0-1) ...
Selecting previously unselected package libxfixes3:arm64.
Preparing to unpack .../06-libxfixes3_1%3a5.0.3-2_arm64.deb ...
Unpacking libxfixes3:arm64 (1:5.0.3-2) ...
Selecting previously unselected package libva-x11-2:arm64.
Preparing to unpack .../07-libva-x11-2_2.10.0-1_arm64.deb ...
Unpacking libva-x11-2:arm64 (2.10.0-1) ...
Selecting previously unselected package libvdpau1:arm64.
Preparing to unpack .../08-libvdpau1_1.4-3_arm64.deb ...
Unpacking libvdpau1:arm64 (1.4-3) ...
Selecting previously unselected package ocl-icd-libopencl1:arm64.
Preparing to unpack .../09-ocl-icd-libopencl1_2.2.14-2_arm64.deb ...
Unpacking ocl-icd-libopencl1:arm64 (2.2.14-2) ...
Selecting previously unselected package libavutil56:arm64.
Preparing to unpack .../10-libavutil56_7%3a4.3.5-0+deb11u1+rpt3_arm64.deb ...
Unpacking libavutil56:arm64 (7:4.3.5-0+deb11u1+rpt3) ...
Selecting previously unselected package libpixman-1-0:arm64.
Preparing to unpack .../11-libpixman-1-0_0.40.0-1.1~deb11u1+rpt1_arm64.deb ...
Unpacking libpixman-1-0:arm64 (0.40.0-1.1~deb11u1+rpt1) ...
Selecting previously unselected package libxcb-render0:arm64.
Preparing to unpack .../12-libxcb-render0_1.14-3_arm64.deb ...
Unpacking libxcb-render0:arm64 (1.14-3) ...
Selecting previously unselected package libxcb-shm0:arm64.
Preparing to unpack .../13-libxcb-shm0_1.14-3_arm64.deb ...
Unpacking libxcb-shm0:arm64 (1.14-3) ...
Selecting previously unselected package libxrender1:arm64.
Preparing to unpack .../14-libxrender1_1%3a0.9.10-1_arm64.deb ...
Unpacking libxrender1:arm64 (1:0.9.10-1) ...
Selecting previously unselected package libcairo2:arm64.
Preparing to unpack .../15-libcairo2_1.16.0-5+rpt1_arm64.deb ...
Unpacking libcairo2:arm64 (1.16.0-5+rpt1) ...
Selecting previously unselected package libcodec2-0.9:arm64.
Preparing to unpack .../16-libcodec2-0.9_0.9.2-4_arm64.deb ...
Unpacking libcodec2-0.9:arm64 (0.9.2-4) ...
Selecting previously unselected package libdav1d4:arm64.
Preparing to unpack .../17-libdav1d4_0.7.1-3_arm64.deb ...
Unpacking libdav1d4:arm64 (0.7.1-3) ...
Selecting previously unselected package libgsm1:arm64.
Preparing to unpack .../18-libgsm1_1.0.18-2_arm64.deb ...
Unpacking libgsm1:arm64 (1.0.18-2) ...
Selecting previously unselected package libmp3lame0:arm64.
Preparing to unpack .../19-libmp3lame0_3.100-3_arm64.deb ...
Unpacking libmp3lame0:arm64 (3.100-3) ...
Selecting previously unselected package libopus0:arm64.
Preparing to unpack .../20-libopus0_1.3.1-0.1_arm64.deb ...
Unpacking libopus0:arm64 (1.3.1-0.1) ...
Selecting previously unselected package libcairo-gobject2:arm64.
Preparing to unpack .../21-libcairo-gobject2_1.16.0-5+rpt1_arm64.deb ...
Unpacking libcairo-gobject2:arm64 (1.16.0-5+rpt1) ...
Selecting previously unselected package libgdk-pixbuf2.0-common.
Preparing to unpack .../22-libgdk-pixbuf2.0-common_2.42.2+dfsg-1+deb11u1_all.deb ...
Unpacking libgdk-pixbuf2.0-common (2.42.2+dfsg-1+deb11u1) ...
Selecting previously unselected package shared-mime-info.
Preparing to unpack .../23-shared-mime-info_2.0-1_arm64.deb ...
Unpacking shared-mime-info (2.0-1) ...
Selecting previously unselected package libgdk-pixbuf-2.0-0:arm64.
Preparing to unpack .../24-libgdk-pixbuf-2.0-0_2.42.2+dfsg-1+deb11u1_arm64.deb ...
Unpacking libgdk-pixbuf-2.0-0:arm64 (2.42.2+dfsg-1+deb11u1) ...
Selecting previously unselected package libfribidi0:arm64.
Preparing to unpack .../25-libfribidi0_1.0.8-2+deb11u1_arm64.deb ...
Unpacking libfribidi0:arm64 (1.0.8-2+deb11u1) ...
Selecting previously unselected package libgraphite2-3:arm64.
Preparing to unpack .../26-libgraphite2-3_1.3.14-1_arm64.deb ...
Unpacking libgraphite2-3:arm64 (1.3.14-1) ...
Selecting previously unselected package libharfbuzz0b:arm64.
Preparing to unpack .../27-libharfbuzz0b_2.7.4-1_arm64.deb ...
Unpacking libharfbuzz0b:arm64 (2.7.4-1) ...
Selecting previously unselected package libthai-data.
Preparing to unpack .../28-libthai-data_0.1.28-3_all.deb ...
Unpacking libthai-data (0.1.28-3) ...
Selecting previously unselected package libdatrie1:arm64.
Preparing to unpack .../29-libdatrie1_0.2.13-1_arm64.deb ...
Unpacking libdatrie1:arm64 (0.2.13-1) ...
Selecting previously unselected package libthai0:arm64.
Preparing to unpack .../30-libthai0_0.1.28-3_arm64.deb ...
Unpacking libthai0:arm64 (0.1.28-3) ...
Selecting previously unselected package libpango-1.0-0:arm64.
Preparing to unpack .../31-libpango-1.0-0_1.46.2-3_arm64.deb ...
Unpacking libpango-1.0-0:arm64 (1.46.2-3) ...
Selecting previously unselected package libpangoft2-1.0-0:arm64.
Preparing to unpack .../32-libpangoft2-1.0-0_1.46.2-3_arm64.deb ...
Unpacking libpangoft2-1.0-0:arm64 (1.46.2-3) ...
Selecting previously unselected package libpangocairo-1.0-0:arm64.
Preparing to unpack .../33-libpangocairo-1.0-0_1.46.2-3_arm64.deb ...
Unpacking libpangocairo-1.0-0:arm64 (1.46.2-3) ...
Selecting previously unselected package librsvg2-2:arm64.
Preparing to unpack .../34-librsvg2-2_2.50.3+dfsg-1_arm64.deb ...
Unpacking librsvg2-2:arm64 (2.50.3+dfsg-1) ...
Selecting previously unselected package libshine3:arm64.
Preparing to unpack .../35-libshine3_3.1.1-2_arm64.deb ...
Unpacking libshine3:arm64 (3.1.1-2) ...
Selecting previously unselected package libsnappy1v5:arm64.
Preparing to unpack .../36-libsnappy1v5_1.1.8-1_arm64.deb ...
Unpacking libsnappy1v5:arm64 (1.1.8-1) ...
Selecting previously unselected package libspeex1:arm64.
Preparing to unpack .../37-libspeex1_1.2~rc1.2-1.1_arm64.deb ...
Unpacking libspeex1:arm64 (1.2~rc1.2-1.1) ...
Selecting previously unselected package libsoxr0:arm64.
Preparing to unpack .../38-libsoxr0_0.1.3-4_arm64.deb ...
Unpacking libsoxr0:arm64 (0.1.3-4) ...
Selecting previously unselected package libswresample3:arm64.
Preparing to unpack .../39-libswresample3_7%3a4.3.5-0+deb11u1+rpt3_arm64.deb ...
Unpacking libswresample3:arm64 (7:4.3.5-0+deb11u1+rpt3) ...
Selecting previously unselected package libtheora0:arm64.
Preparing to unpack .../40-libtheora0_1.1.1+dfsg.1-15_arm64.deb ...
Unpacking libtheora0:arm64 (1.1.1+dfsg.1-15) ...
Selecting previously unselected package libtwolame0:arm64.
Preparing to unpack .../41-libtwolame0_0.4.0-2_arm64.deb ...
Unpacking libtwolame0:arm64 (0.4.0-2) ...
Selecting previously unselected package libvorbisenc2:arm64.
Preparing to unpack .../42-libvorbisenc2_1.3.7-1_arm64.deb ...
Unpacking libvorbisenc2:arm64 (1.3.7-1) ...
Selecting previously unselected package libvpx6:arm64.
Preparing to unpack .../43-libvpx6_1.9.0-1_arm64.deb ...
Unpacking libvpx6:arm64 (1.9.0-1) ...
Selecting previously unselected package libwavpack1:arm64.
Preparing to unpack .../44-libwavpack1_5.4.0-1_arm64.deb ...
Unpacking libwavpack1:arm64 (5.4.0-1) ...
Selecting previously unselected package libx264-160:arm64.
Preparing to unpack .../45-libx264-160_2%3a0.160.3011+gitcde9a93-2.1_arm64.deb ...
Unpacking libx264-160:arm64 (2:0.160.3011+gitcde9a93-2.1) ...
Selecting previously unselected package libnuma1:arm64.
Preparing to unpack .../46-libnuma1_2.0.12-1+b1_arm64.deb ...
Unpacking libnuma1:arm64 (2.0.12-1+b1) ...
Selecting previously unselected package libx265-192:arm64.
Preparing to unpack .../47-libx265-192_3.4-2_arm64.deb ...
Unpacking libx265-192:arm64 (3.4-2) ...
Selecting previously unselected package BANNED:arm64.
Preparing to unpack .../48-BANNED_2%3a1.3.7-1_arm64.deb ...
Unpacking BANNED:arm64 (2:1.3.7-1) ...
Selecting previously unselected package libzvbi-common.
Preparing to unpack .../49-libzvbi-common_0.2.35-18_all.deb ...
Unpacking libzvbi-common (0.2.35-18) ...
Selecting previously unselected package libzvbi0:arm64.
Preparing to unpack .../50-libzvbi0_0.2.35-18_arm64.deb ...
Unpacking libzvbi0:arm64 (0.2.35-18) ...
Selecting previously unselected package libavcodec58:arm64.
Preparing to unpack .../51-libavcodec58_7%3a4.3.5-0+deb11u1+rpt3_arm64.deb ...
Unpacking libavcodec58:arm64 (7:4.3.5-0+deb11u1+rpt3) ...
Selecting previously unselected package libavresample4:arm64.
Preparing to unpack .../52-libavresample4_7%3a4.3.5-0+deb11u1+rpt3_arm64.deb ...
Unpacking libavresample4:arm64 (7:4.3.5-0+deb11u1+rpt3) ...
Selecting previously unselected package libjack-jackd2-0:arm64.
Preparing to unpack .../53-libjack-jackd2-0_1.9.17~dfsg-1_arm64.deb ...
Unpacking libjack-jackd2-0:arm64 (1.9.17~dfsg-1) ...
Selecting previously unselected package libasyncns0:arm64.
Preparing to unpack .../54-libasyncns0_0.8-6+b2_arm64.deb ...
Unpacking libasyncns0:arm64 (0.8-6+b2) ...
Selecting previously unselected package libsndfile1:arm64.
Preparing to unpack .../55-libsndfile1_1.0.31-2_arm64.deb ...
Unpacking libsndfile1:arm64 (1.0.31-2) ...
Selecting previously unselected package libpulse0:arm64.
Preparing to unpack .../56-libpulse0_14.2-2+rpt1_arm64.deb ...
Unpacking libpulse0:arm64 (14.2-2+rpt1) ...
Selecting previously unselected package libasound2-plugins:arm64.
Preparing to unpack .../57-libasound2-plugins_1.2.2-2_arm64.deb ...
Unpacking libasound2-plugins:arm64 (1.2.2-2) ...
Selecting previously unselected package libdrm-amdgpu1:arm64.
Preparing to unpack .../58-libdrm-amdgpu1_2.4.104-1_arm64.deb ...
Unpacking libdrm-amdgpu1:arm64 (2.4.104-1) ...
Selecting previously unselected package libdrm-nouveau2:arm64.
Preparing to unpack .../59-libdrm-nouveau2_2.4.104-1_arm64.deb ...
Unpacking libdrm-nouveau2:arm64 (2.4.104-1) ...
Selecting previously unselected package libdrm-radeon1:arm64.
Preparing to unpack .../60-libdrm-radeon1_2.4.104-1_arm64.deb ...
Unpacking libdrm-radeon1:arm64 (2.4.104-1) ...
Selecting previously unselected package libgdk-pixbuf2.0-bin.
Preparing to unpack .../61-libgdk-pixbuf2.0-bin_2.42.2+dfsg-1+deb11u1_arm64.deb ...
Unpacking libgdk-pixbuf2.0-bin (2.42.2+dfsg-1+deb11u1) ...
Selecting previously unselected package libglapi-mesa:arm64.
Preparing to unpack .../62-libglapi-mesa_20.3.5-1+rpt4+rpi1_arm64.deb ...
Unpacking libglapi-mesa:arm64 (20.3.5-1+rpt4+rpi1) ...
Selecting previously unselected package libz3-4:arm64.
Preparing to unpack .../63-libz3-4_4.8.10-1_arm64.deb ...
Unpacking libz3-4:arm64 (4.8.10-1) ...
Selecting previously unselected package libllvm11:arm64.
Preparing to unpack .../64-libllvm11_1%3a11.0.1-2_arm64.deb ...
Unpacking libllvm11:arm64 (1:11.0.1-2) ...
Selecting previously unselected package libsensors-config.
Preparing to unpack .../65-libsensors-config_1%3a3.6.0-7_all.deb ...
Unpacking libsensors-config (1:3.6.0-7) ...
Selecting previously unselected package libsensors5:arm64.
Preparing to unpack .../66-libsensors5_1%3a3.6.0-7_arm64.deb ...
Unpacking libsensors5:arm64 (1:3.6.0-7) ...
Selecting previously unselected package libvulkan1:arm64.
Preparing to unpack .../67-libvulkan1_1.2.162.0-1_arm64.deb ...
Unpacking libvulkan1:arm64 (1.2.162.0-1) ...
Selecting previously unselected package libwayland-client0:arm64.
Preparing to unpack .../68-libwayland-client0_1.18.0-2~exp1.1_arm64.deb ...
Unpacking libwayland-client0:arm64 (1.18.0-2~exp1.1) ...
Selecting previously unselected package libgl1-mesa-dri:arm64.
Preparing to unpack .../69-libgl1-mesa-dri_20.3.5-1+rpt4+rpi1_arm64.deb ...
Unpacking libgl1-mesa-dri:arm64 (20.3.5-1+rpt4+rpi1) ...
Selecting previously unselected package libglvnd0:arm64.
Preparing to unpack .../70-libglvnd0_1.3.2-1_arm64.deb ...
Unpacking libglvnd0:arm64 (1.3.2-1) ...
Selecting previously unselected package libx11-xcb1:arm64.
Preparing to unpack .../71-libx11-xcb1_2%3a1.7.2-1_arm64.deb ...
Unpacking libx11-xcb1:arm64 (2:1.7.2-1) ...
Selecting previously unselected package libxcb-dri2-0:arm64.
Preparing to unpack .../72-libxcb-dri2-0_1.14-3_arm64.deb ...
Unpacking libxcb-dri2-0:arm64 (1.14-3) ...
Selecting previously unselected package libxcb-dri3-0:arm64.
Preparing to unpack .../73-libxcb-dri3-0_1.14-3_arm64.deb ...
Unpacking libxcb-dri3-0:arm64 (1.14-3) ...
Selecting previously unselected package libxcb-glx0:arm64.
Preparing to unpack .../74-libxcb-glx0_1.14-3_arm64.deb ...
Unpacking libxcb-glx0:arm64 (1.14-3) ...
Selecting previously unselected package libxcb-present0:arm64.
Preparing to unpack .../75-libxcb-present0_1.14-3_arm64.deb ...
Unpacking libxcb-present0:arm64 (1.14-3) ...
Selecting previously unselected package libxcb-sync1:arm64.
Preparing to unpack .../76-libxcb-sync1_1.14-3_arm64.deb ...
Unpacking libxcb-sync1:arm64 (1.14-3) ...
Selecting previously unselected package libxcb-xfixes0:arm64.
Preparing to unpack .../77-libxcb-xfixes0_1.14-3_arm64.deb ...
Unpacking libxcb-xfixes0:arm64 (1.14-3) ...
Selecting previously unselected package libxdamage1:arm64.
Preparing to unpack .../78-libxdamage1_1%3a1.1.5-2_arm64.deb ...
Unpacking libxdamage1:arm64 (1:1.1.5-2) ...
Selecting previously unselected package libxshmfence1:arm64.
Preparing to unpack .../79-libxshmfence1_1.3-1_arm64.deb ...
Unpacking libxshmfence1:arm64 (1.3-1) ...
Selecting previously unselected package libxxf86vm1:arm64.
Preparing to unpack .../80-libxxf86vm1_1%3a1.1.4-1+b2_arm64.deb ...
Unpacking libxxf86vm1:arm64 (1:1.1.4-1+b2) ...
Selecting previously unselected package libglx-mesa0:arm64.
Preparing to unpack .../81-libglx-mesa0_20.3.5-1+rpt4+rpi1_arm64.deb ...
Unpacking libglx-mesa0:arm64 (20.3.5-1+rpt4+rpi1) ...
Selecting previously unselected package librsvg2-common:arm64.
Preparing to unpack .../82-librsvg2-common_2.50.3+dfsg-1_arm64.deb ...
Unpacking librsvg2-common:arm64 (2.50.3+dfsg-1) ...
Selecting previously unselected package libglx0:arm64.
Preparing to unpack .../83-libglx0_1.3.2-1_arm64.deb ...
Unpacking libglx0:arm64 (1.3.2-1) ...
Selecting previously unselected package libgl1:arm64.
Preparing to unpack .../84-libgl1_1.3.2-1_arm64.deb ...
Unpacking libgl1:arm64 (1.3.2-1) ...
Selecting previously unselected package libvdpau-va-gl1:arm64.
Preparing to unpack .../85-libvdpau-va-gl1_0.4.2-1+b1_arm64.deb ...
Unpacking libvdpau-va-gl1:arm64 (0.4.2-1+b1) ...
Selecting previously unselected package libxcb-randr0:arm64.
Preparing to unpack .../86-libxcb-randr0_1.14-3_arm64.deb ...
Unpacking libxcb-randr0:arm64 (1.14-3) ...
Selecting previously unselected package mesa-va-drivers:arm64.
Preparing to unpack .../87-mesa-va-drivers_20.3.5-1+rpt4+rpi1_arm64.deb ...
Unpacking mesa-va-drivers:arm64 (20.3.5-1+rpt4+rpi1) ...
Selecting previously unselected package mesa-vdpau-drivers:arm64.
Preparing to unpack .../88-mesa-vdpau-drivers_20.3.5-1+rpt4+rpi1_arm64.deb ...
Unpacking mesa-vdpau-drivers:arm64 (20.3.5-1+rpt4+rpi1) ...
Selecting previously unselected package mesa-vulkan-drivers:arm64.
Preparing to unpack .../89-mesa-vulkan-drivers_20.3.5-1+rpt4+rpi1_arm64.deb ...
Unpacking mesa-vulkan-drivers:arm64 (20.3.5-1+rpt4+rpi1) ...
Selecting previously unselected package va-driver-all:arm64.
Preparing to unpack .../90-va-driver-all_2.10.0-1_arm64.deb ...
Unpacking va-driver-all:arm64 (2.10.0-1) ...
Selecting previously unselected package vdpau-driver-all:arm64.
Preparing to unpack .../91-vdpau-driver-all_1.4-3_arm64.deb ...
Unpacking vdpau-driver-all:arm64 (1.4-3) ...
Setting up libgraphite2-3:arm64 (1.3.14-1) ...
Setting up libxcb-dri3-0:arm64 (1.14-3) ...
Setting up libpixman-1-0:arm64 (0.40.0-1.1~deb11u1+rpt1) ...
Setting up libx11-xcb1:arm64 (2:1.7.2-1) ...
Setting up fontconfig (2.13.1-4.2) ...
Regenerating fonts cache... done.
Setting up libdrm-nouveau2:arm64 (2.4.104-1) ...
Setting up libxdamage1:arm64 (1:1.1.5-2) ...
Setting up libxcb-xfixes0:arm64 (1.14-3) ...
Setting up libspeex1:arm64 (1.2~rc1.2-1.1) ...
Setting up libshine3:arm64 (3.1.1-2) ...
Setting up libtwolame0:arm64 (0.4.0-2) ...
Setting up libxrender1:arm64 (1:0.9.10-1) ...
Setting up libdatrie1:arm64 (0.2.13-1) ...
Setting up libgsm1:arm64 (1.0.18-2) ...
Setting up libxcb-render0:arm64 (1.14-3) ...
Setting up libsoxr0:arm64 (0.1.3-4) ...
Setting up libdrm-radeon1:arm64 (2.4.104-1) ...
Setting up libglvnd0:arm64 (1.3.2-1) ...
Setting up libxcb-glx0:arm64 (1.14-3) ...
Setting up libaom0:arm64 (1.0.0.errata1-3) ...
Setting up libgdk-pixbuf2.0-common (2.42.2+dfsg-1+deb11u1) ...
Setting up libsensors-config (1:3.6.0-7) ...
Setting up libxcb-shm0:arm64 (1.14-3) ...
Setting up BANNED:arm64 (2:1.3.7-1) ...
Setting up libx264-160:arm64 (2:0.160.3011+gitcde9a93-2.1) ...
Setting up libcairo2:arm64 (1.16.0-5+rpt1) ...
Setting up libxxf86vm1:arm64 (1:1.1.4-1+b2) ...
Setting up libsnappy1v5:arm64 (1.1.8-1) ...
Setting up libxcb-present0:arm64 (1.14-3) ...
Setting up libz3-4:arm64 (4.8.10-1) ...
Setting up libllvm11:arm64 (1:11.0.1-2) ...
Setting up libva2:arm64 (2.10.0-1) ...
Setting up libxfixes3:arm64 (1:5.0.3-2) ...
Setting up libxcb-sync1:arm64 (1.14-3) ...
Setting up libcodec2-0.9:arm64 (0.9.2-4) ...
Setting up libfribidi0:arm64 (1.0.8-2+deb11u1) ...
Setting up libopus0:arm64 (1.3.1-0.1) ...
Setting up shared-mime-info (2.0-1) ...
Setting up libsensors5:arm64 (1:3.6.0-7) ...
Setting up libglapi-mesa:arm64 (20.3.5-1+rpt4+rpi1) ...
Setting up libvulkan1:arm64 (1.2.162.0-1) ...
Setting up libxcb-dri2-0:arm64 (1.14-3) ...
Setting up libnuma1:arm64 (2.0.12-1+b1) ...
Setting up libjack-jackd2-0:arm64 (1.9.17~dfsg-1) ...
Setting up libva-drm2:arm64 (2.10.0-1) ...
Setting up ocl-icd-libopencl1:arm64 (2.2.14-2) ...
Setting up libasyncns0:arm64 (0.8-6+b2) ...
Setting up libxshmfence1:arm64 (1.3-1) ...
Setting up libvpx6:arm64 (1.9.0-1) ...
Setting up libvdpau1:arm64 (1.4-3) ...
Setting up libwavpack1:arm64 (5.4.0-1) ...
Setting up libxcb-randr0:arm64 (1.14-3) ...
Setting up libtheora0:arm64 (1.1.1+dfsg.1-15) ...
Setting up libdav1d4:arm64 (0.7.1-3) ...
Setting up libharfbuzz0b:arm64 (2.7.4-1) ...
Setting up libthai-data (0.1.28-3) ...
Setting up libgdk-pixbuf-2.0-0:arm64 (2.42.2+dfsg-1+deb11u1) ...
Setting up libcairo-gobject2:arm64 (1.16.0-5+rpt1) ...
Setting up libva-x11-2:arm64 (2.10.0-1) ...
Setting up libzvbi-common (0.2.35-18) ...
Setting up libmp3lame0:arm64 (3.100-3) ...
Setting up dctrl-tools (2.24-3) ...
Setting up libvorbisenc2:arm64 (1.3.7-1) ...
Setting up libdrm-amdgpu1:arm64 (2.4.104-1) ...
Setting up libwayland-client0:arm64 (1.18.0-2~exp1.1) ...
Setting up mesa-vulkan-drivers:arm64 (20.3.5-1+rpt4+rpi1) ...
Setting up mesa-vdpau-drivers:arm64 (20.3.5-1+rpt4+rpi1) ...
Setting up libzvbi0:arm64 (0.2.35-18) ...
Setting up libgl1-mesa-dri:arm64 (20.3.5-1+rpt4+rpi1) ...
Setting up libx265-192:arm64 (3.4-2) ...
Setting up libavutil56:arm64 (7:4.3.5-0+deb11u1+rpt3) ...
Setting up dkms (2.8.4-3) ...
Setting up libthai0:arm64 (0.1.28-3) ...
Setting up libgdk-pixbuf2.0-bin (2.42.2+dfsg-1+deb11u1) ...
Setting up libsndfile1:arm64 (1.0.31-2) ...
Setting up mesa-va-drivers:arm64 (20.3.5-1+rpt4+rpi1) ...
Setting up libglx-mesa0:arm64 (20.3.5-1+rpt4+rpi1) ...
Setting up libglx0:arm64 (1.3.2-1) ...
Setting up libpulse0:arm64 (14.2-2+rpt1) ...
Setting up libpango-1.0-0:arm64 (1.46.2-3) ...
Setting up libswresample3:arm64 (7:4.3.5-0+deb11u1+rpt3) ...
Setting up libavresample4:arm64 (7:4.3.5-0+deb11u1+rpt3) ...
Setting up libgl1:arm64 (1.3.2-1) ...
Setting up va-driver-all:arm64 (2.10.0-1) ...
Setting up libpangoft2-1.0-0:arm64 (1.46.2-3) ...
Setting up libvdpau-va-gl1:arm64 (0.4.2-1+b1) ...
Setting up libpangocairo-1.0-0:arm64 (1.46.2-3) ...
Setting up librsvg2-2:arm64 (2.50.3+dfsg-1) ...
Setting up librsvg2-common:arm64 (2.50.3+dfsg-1) ...
Setting up vdpau-driver-all:arm64 (1.4-3) ...
Setting up libavcodec58:arm64 (7:4.3.5-0+deb11u1+rpt3) ...
Setting up libasound2-plugins:arm64 (1.2.2-2) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u5) ...
Processing triggers for libgdk-pixbuf-2.0-0:arm64 (2.42.2+dfsg-1+deb11u1) ...
grep: /boot/kernel.img: No such file or directory

gzip: stdin: unexpected end of file
grep: /boot/kernel.img: No such file or directory

gzip: stdin: unexpected end of file

Creating symlink /var/lib/dkms/seeed-voicecard/0.3/source ->
                 /usr/src/seeed-voicecard-0.3

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j4 KERNELRELEASE=5.15.84-v8+ -C /lib/modules/5.15.84-v8+/build M=/var/lib/dkms/seeed-voicecard/0.3/build....
cleaning build area...

DKMS: build completed.

snd-soc-wm8960.ko.xz:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.15.84-v8+/updates/dkms/

snd-soc-ac108.ko.xz:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.15.84-v8+/updates/dkms/

snd-soc-seeed-voicecard.ko.xz:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.15.84-v8+/updates/dkms/

depmod....

DKMS: install completed.
setup git config
git init
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
Initialized empty Git repository in /etc/voicecard/.git/
git add --all
git commit -m "origin configures"
[master (root-commit) 8572a79] origin configures
 7 files changed, 1482 insertions(+)
 create mode 100644 ac108_6mic.state
 create mode 100644 ac108_asound.state
 create mode 100644 asound_2mic.conf
 create mode 100644 asound_4mic.conf
 create mode 100644 asound_6mic.conf
 create mode 100644 dkms.conf
 create mode 100644 wm8960_asound.state
Created symlink /etc/systemd/system/sysinit.target.wants/seeed-voicecard.service → /lib/systemd/system/seeed-voicecard.service.
------------------------------------------------------
Please reboot your raspberry pi to apply all settings
Enjoy!
------------------------------------------------------
pi@raspberrypi:~/seeed-voicecard $ sudo reboot
Connection to raspberrypi.local closed by remote host.
Connection to raspberrypi.local closed.
melissa@Melissa-MacBook-Pro-3 ~ [255]> ssh pi@raspberrypi.local
pi@raspberrypi.local's password:
\Linux raspberrypi 5.15.84-v8+ #1613 SMP PREEMPT Thu Jan 5 12:03:08 GMT 2023 aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Tue Jan 24 16:13:34 2023 from 2601:1c0:ce01:2460:9939:1ee2:fd27:1d41
pi@raspberrypi:~ $ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 2: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 [bcm2835-i2s-wm8960-hifi wm8960-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
pi@raspberrypi:~ $ alsamixer
pi@raspberrypi:~ $ speaker-test -c2

speaker-test 1.2.4

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 12000 to 18000
Period size range from 6000 to 6000
Using max buffer size 18000
Periods = 4
was set period_size = 6000
was set buffer_size = 18000
 0 - Front Left
 1 - Front Right
Time per period = 5.745404
 0 - Front Left
 1 - Front Right
^CWrite error: -4,Interrupted system call
xrun_recovery failed: -4,Interrupted system call
Transfer failed: Interrupted system call
pi@raspberrypi:~ $ ls
Raspberry-Pi-Installer-Scripts  raspi-blinka.py  seeed-voicecard
pi@raspberrypi:~ $ sudo arecord -f cd -Dhw:2 | aplay -Dhw:2
Recording WAVE 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Playing WAVE 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
I'd recommend running the sound module install again if you still have the buster 64 lite sd card, otherwise if you just go through it again, it'll probably work on a second attempt.

User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Thank you very much, Melissa. I am wondering if I'm running a different version of the install.sh... I am running the one under the seeed-voicecard/ directory. The output I get is very different from the one you get. Please take a look at my posts from Friday Jan 20 1t 10:07 PM (not sure if that time is EST, or CST which is my time zone). From the listing you posted it seems that many of the commands that I entered by hand were actually executed from the install.sh procedure. I entered by hand:

1) sudo apt-get install -y git
2) git clone https://github.com/HinTak/seeed-voicecard
3) cd seeed-voicecard/
4) git checkout v5.9
5) sudo ./install.sh

The output from 1) and 2) appear in your listing after you execute ./install.sh. Perhaps you did some cut and paste of the output from the commands?

In any case, a lot of the output lines from your listing is totally different from my output. I am using the very last version of Bullseye lite 64 bit. Is that what you're using?

User avatar
MakerMelissa
 
Posts: 334
Joined: Wed Jun 05, 2013 2:10 am

Re: braincraft hat. Error when testing hat microphone

Post by MakerMelissa »

Yeah, I executed all the commands you had listed and also used the latest version of Raspberry Pi Lite and as far as I can tell you typed everything right. I did notice in your output it has:

E: Unable to locate package linux-raspi
E: Unable to locate package linux-headers-raspi
E: Unable to locate package linux-image-raspi

The E is for Error. That's why I thought it was just a bad install. Sometimes it can happen for no obvious reason and the solution is to just retry.

Melissa

User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Hello Melissa,

Yes, that's why I highlighted those three lines in red. Now, the interesting thing is that you got exactly the same errors... Yet, a lot of the remaining the output is quite different. So, I'm totally lost here. Again: I get it working with the lite version of Buster. I can't use it because Tensor lite doesn't support that OS, which forces me to use Bullseye 64 bit lite. Do you have any other ideas?

User avatar
MakerMelissa
 
Posts: 334
Joined: Wed Jun 05, 2013 2:10 am

Re: braincraft hat. Error when testing hat microphone

Post by MakerMelissa »

Oops, I meant to try again with Bullseye Lite 64, not Buster. It was probably just a fluke.

User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Incidentally, I also had trouble getting the camera to work when using Bullseye, while it worked perfectly well with Buster. Perhaps the problem is related to the microphone problem, and once the microphone problem is solved so will the camera issue. But let's take one step at a time.

User avatar
MakerMelissa
 
Posts: 334
Joined: Wed Jun 05, 2013 2:10 am

Re: braincraft hat. Error when testing hat microphone

Post by MakerMelissa »

The camera issue is not related to the sound driver issues. While updating the guide, I spent time thoroughly testing various camera configurations. I wasn't able to get the camera working in the lite version of Bullseye at the time of updating the guide, which is why it's written for the desktop version. However, I filed it at the time at https://github.com/raspberrypi/picamera2/issues/339 and tested that it was working a little afterwards, but it's possible it has broken again since.

To get it running, you need to enable the FKMS driver, which is the same one Buster uses, and to do that you will need to follow this section:
https://learn.adafruit.com/running-tens ... er-3128739

Thanks,
Melissa

User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Thank you, Melissa. I'll wait for the microphone issue to be solved before I tackle the camera.

User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Hello Melissa,

Any progress on the Bullseye Lite microphone installation for the braincraft hat?

Thank you,

Pedro

User avatar
MakerMelissa
 
Posts: 334
Joined: Wed Jun 05, 2013 2:10 am

Re: braincraft hat. Error when testing hat microphone

Post by MakerMelissa »

It worked for me without making any changes. I was waiting on you to try installing again. Like I mentioned, I think maybe some server wasn't available at the moment you tried installing and you should try again.

Melissa

User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Mmm. I thought you tested it with Buster but not with Bullseye. Buster works for me, but then I can't install Tensor Flow... I'd have expected that a non-available server would have given an installation error...

Could you please confirm that you tested with 64-bit Bullseye lite? If you did, I'll do an install from scratch again, using Bullseye 64-bit lite.

Thanks again for your support

User avatar
MakerMelissa
 
Posts: 334
Joined: Wed Jun 05, 2013 2:10 am

Re: braincraft hat. Error when testing hat microphone

Post by MakerMelissa »

Yes I tested it successfully in both the desktop and lite versions of 64-bit Bullseye, not Buster.

User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Thank you, Melissa. I'll try again with a fresh install of Bullseye lite and will get back to you.

User avatar
pjrestrepo
 
Posts: 40
Joined: Sun Apr 15, 2012 7:43 pm

Re: braincraft hat. Error when testing hat microphone

Post by pjrestrepo »

Hello Melissa,

Thank you very much. Everything is working now, including the camera and the display.

Thanks again!

Post Reply
Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

Return to “Adafruit Raspberry Pi® accessories”