๐Ÿ“ฃ๐Ÿ“ช ๐Ÿšš Adafruit will not be shipping USPS orders Monday October 14, 2019 ๐Ÿ—“. Expedited USPS orders placed after 11am ET ๐Ÿ•š Friday October 11 will go out Tuesday October 15 ๐Ÿ“ฃ๐Ÿ“ช๐Ÿšš
0

MIDI Sync issue.continues pattern regardless of master
Moderators: altitude, adafruit_support_bill, adafruit, phono, hamburgers

Please be positive and constructive with your questions and comments.

MIDI Sync issue.continues pattern regardless of master

by floatation on Sat Mar 25, 2006 11:38 pm

Hi-
Ok, one more problem. I have a MPC 2000 xl as my master sequencer.
When I start and stop my mpc, the box stops and starts where it left off, instead of going back to the beginning.
I am hoping this is software related, so I am going to re-install the OS. I am not sure what OS is in there now so I figure I would give this a shot..
Has this happened to anyone? And if so, was it physical or OS related?

thanks-
floatation
 
Posts: 13
Joined: Mon Feb 06, 2006 9:39 pm
Location: La Jolla

by adafruit on Sun Mar 26, 2006 1:49 am

thats because your box sends MIDI CONTINUE instead of MIDI START, the x0x is doing the right thing, just getting the wrong messages!

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by floatation on Sun Mar 26, 2006 3:09 am

ladyada wrote:thats because your box sends MIDI CONTINUE instead of MIDI START, the x0x is doing the right thing, just getting the wrong messages!

The MPC is sending a standard MIDI CLOCK. I have never had any issues with sending standard MIDI CLOCK with any other gear, such as 808's 303's and 202's.
THe x0x cannot sync correctly when its a MASTER either. Floats all over the place regardless if its syncing another 303 (via a doefper sync box) or the MPC.
Is there anything else that could be the issue? Someone mentioned in another post that they had issues with the MIDI sync so I am not sure if this was perhaps a similiar issue.
Does anyone out there use a MPC 2000XL with this box?
thanks-


floatation
 
Posts: 13
Joined: Mon Feb 06, 2006 9:39 pm
Location: La Jolla

by floatation on Sun Mar 26, 2006 3:20 am

ladyada wrote:thats because your box sends MIDI CONTINUE instead of MIDI START, the x0x is doing the right thing, just getting the wrong messages!


If that was the case, I would think that all my gear would stop/continue midway through. My 303's 808's etc all go directly back to the beginning when using the MPC. I had 909's sync correctly as well.
floatation
 
Posts: 13
Joined: Mon Feb 06, 2006 9:39 pm
Location: La Jolla

by altitude on Sun Mar 26, 2006 7:38 am

I have never had any issues with sending standard MIDI CLOCK with any other gear, such as 808's 303's and 202's


808s, 303's and 202s do not have midi so i'm not quite sure how u are sending midi clock to them but I would just sniff the midi coming out of the MPC and see what its sending

altitude
 
Posts: 995
Joined: Wed May 11, 2005 5:17 pm

by floatation on Sun Mar 26, 2006 12:10 pm

Altitude wrote:
I have never had any issues with sending standard MIDI CLOCK with any other gear, such as 808's 303's and 202's


808s, 303's and 202s do not have midi so i'm not quite sure how u are sending midi clock to them but I would just sniff the midi coming out of the MPC and see what its sending

Hi-
The MIDICLOCK is converted to DIN sync with the DOEPHER I have. The 808's etc, dont have MIDI obviously as you stated. So the point is that the MPC works fine when working with 80's technology and the MPC is sending standard clock to other MIDI gear such as a R8 MK2, and its known to sync to ELectribes, etc..
So I dont think its the MPC..
floatation
 
Posts: 13
Joined: Mon Feb 06, 2006 9:39 pm
Location: La Jolla

by altitude on Sun Mar 26, 2006 12:22 pm

Ah, makes sense.

This was discussed a while ago and IIRC was fixed in bios 1.04

altitude
 
Posts: 995
Joined: Wed May 11, 2005 5:17 pm

by stevedood on Wed Mar 12, 2008 7:34 pm

I was going through this last night and also having difficulties.
I basically want the x0x the follow the tempo of my MPC but follow it's own internal sequences. I've managed to get some communication going, but the x0x seems to play only the first note and then stop. Perhaps this is a MIDI continue vrs. start issue? I was trying to determine in the MPC setting where I might be able to adjsut this?

I'm using an MPC 2500 and just trying to sync tempos with the MPC as master, that's all, and I have a Motu MIDI Express XT which I can use to filter the MIDI data coming from the MPC if need be.

Any advice appreciated.
Thanks,

Steve
stevedood
 
Posts: 22
Joined: Thu Sep 06, 2007 2:04 pm

Re: MIDI Sync issue.continues pattern regardless of master

by rarara on Thu Mar 13, 2008 4:00 am

floatation wrote:Hi-
Ok, one more problem. I have a MPC 2000 xl as my master sequencer.
When I start and stop my mpc, the box stops and starts where it left off, instead of going back to the beginning.
I am hoping this is software related, so I am going to re-install the OS. I am not sure what OS is in there now so I figure I would give this a shot..
Has this happened to anyone? And if so, was it physical or OS related?

thanks-


i too have the 2000xl, but i'm a bit confused as to what you would want to do. are you saying that you want to stop the mpc, but have the x0x pattern go back to the start, while the mpc then carries on where it stopped? i'm not sure the point of this in practical use?

what i have been trying to do though, is have the mpc play 2 bars of 4/4, but the x0x play a pattern of for instance 15 steps, to produce polyrhythms. is this possible?
rarara
 
Posts: 169
Joined: Wed Apr 05, 2006 9:47 am

by s o l v e n t on Thu Mar 20, 2008 11:13 pm

floatation wrote:
Altitude wrote:
I have never had any issues with sending standard MIDI CLOCK with any other gear, such as 808's 303's and 202's


808s, 303's and 202s do not have midi so i'm not quite sure how u are sending midi clock to them but I would just sniff the midi coming out of the MPC and see what its sending

Hi-
The MIDICLOCK is converted to DIN sync with the DOEPHER I have. The 808's etc, dont have MIDI obviously as you stated. So the point is that the MPC works fine when working with 80's technology and the MPC is sending standard clock to other MIDI gear such as a R8 MK2, and its known to sync to ELectribes, etc..
So I dont think its the MPC..


it sounds to me like LadyAda answered this question correctly upfront... the x0x wants a Midi Start message and your MPC is probably sending a Midi Continue mssg.... the reason that your other sync'd devices may be working is that they recognize Midi Continue=Midi Start ... most devices that are synced to midi clock do this by default or have an option to turn this off or on..... for example i sync my TR-808 via DIN-sync-out on my Kenton Pro-2000, & the Kenton has a Midi Cont=Start ON/OFF option

it is kinda annoying that the x0x doesn't recognize Midi Cont=Start (possible firmware update?), but i'm guessing that you can solve your issue by checking the MPC's Midi Clock out settings so that it always sends a Midi Clock Start mssg when you hit play
s o l v e n t
 
Posts: 5
Joined: Thu Aug 10, 2006 10:09 am
Location: Toronto Canada

by Computer Controlled on Fri Mar 21, 2008 12:41 am

The reason your Roland boxes aren't "Continuing" is because they don't recognize the Continue message. Only start and stop. So it's either your MPC sending out a continue message as stated, or you need a firmware update.
Synths: SH-1 . SH-101 . TB-303 . JX-3P . x0xb0x . uWave II . Alesis Ion . Pro-One w/Synthwood case . MoPho . Monotron

Drum Machines: TR-707 . R-70 . E-MU Procussion
Computer Controlled
 
Posts: 714
Joined: Fri May 06, 2005 5:48 pm
Location: Seattle, WA

by s o l v e n t on Fri Mar 21, 2008 10:37 am

Computer Controlled wrote:The reason your Roland boxes aren't "Continuing" is because they don't recognize the Continue message. Only start and stop. So it's either your MPC sending out a continue message as stated, or you need a firmware update.


if you re-read what he says, his Roland boxes are working fine... probably because his Doepfer recognizes Midi Continue=Midi Start

i also had a problem with this & my x0xb0x -- Logic only sends out Midi Start messages at the beginning of a song, so if you start Logic from any point in the song other than the beginning, it will only send out a Midi Continue message..... and this is FIXED in Logic (grrrr)

luckily for me i also have a Sequentix P3 which allows you to specify Midi Cont=Start... and it has a Sync Out port, so i use that to sync my x0x

i think it would be great if the x0x firmware could be updated to recognize Midi Cont=Midi Start
s o l v e n t
 
Posts: 5
Joined: Thu Aug 10, 2006 10:09 am
Location: Toronto Canada

by Computer Controlled on Fri Mar 21, 2008 2:03 pm

s o l v e n t wrote:
Computer Controlled wrote:The reason your Roland boxes aren't "Continuing" is because they don't recognize the Continue message. Only start and stop. So it's either your MPC sending out a continue message as stated, or you need a firmware update.


if you re-read what he says, his Roland boxes are working fine...


I know, and the reason are ARE working fine is because they don't recognize Continue messages. That's why they are starting up properly.
Synths: SH-1 . SH-101 . TB-303 . JX-3P . x0xb0x . uWave II . Alesis Ion . Pro-One w/Synthwood case . MoPho . Monotron

Drum Machines: TR-707 . R-70 . E-MU Procussion
Computer Controlled
 
Posts: 714
Joined: Fri May 06, 2005 5:48 pm
Location: Seattle, WA

by s o l v e n t on Fri Mar 21, 2008 4:10 pm

Computer Controlled wrote:
s o l v e n t wrote:
Computer Controlled wrote:The reason your Roland boxes aren't "Continuing" is because they don't recognize the Continue message. Only start and stop. So it's either your MPC sending out a continue message as stated, or you need a firmware update.


if you re-read what he says, his Roland boxes are working fine...


I know, and the reason are ARE working fine is because they don't recognize Continue messages. That's why they are starting up properly.


no i think you've got it wrong... the x0xb0x does not recognize Midi Continue messages & that is why it is not starting

the Roland DIN sync boxes start fine because the Doepfer unit (which converts Midi Clock to DIN Sync) is able to recognize a Midi Continue message and treat it like a Midi Start mssg (Midi Continue=Start)

at least this is what i think is happening
s o l v e n t
 
Posts: 5
Joined: Thu Aug 10, 2006 10:09 am
Location: Toronto Canada

by gzifcak on Fri Mar 21, 2008 4:34 pm

the mpc1000 has a "play" button and a "play start" button. the play button sends continue, the play start button sends start.

looks like the mpc2000 has these two as well.
try play start.

i like continue messages, it's best when everything sends and receives both. then you can start and stop wherever you want from one master.

i have had that frustration with logic on multiple occasions though. with something like a daw, where you almost never start from the beginning, you should be able to send start at each bar.
gzifcak
 
Posts: 150
Joined: Wed Oct 26, 2005 3:46 pm
Location: san francisco

Please be positive and constructive with your questions and comments.