Page 1 of 1

no green light!

Posted: Mon Jan 23, 2023 1:37 pm
by seb_kuzminsky
Hi there, I just put together an official Adafruit USBtinyISP kit (product #46), and something's wrong. I'm not getting any activity at all when I plug it into a USB port. No green LED, no new device on the USB bus.

This is on an unremarkable Dell laptop running Linux. USB works fine when I plug in other devices. I have tried multiple USB cables, and both of the USB-A ports on the machine, all give the same results. I tried with an old USB 2.0 hub, same results.

When the board is plugged in, I see +5V between pins 10 and 20 on the attiny. I do not see any oscillation on the oscillator with my oscilloscope, but I don't know if that means anything.

The diodes (2x LED and 2x zener) are in the correct orientation, as is the electrolytic capacitor.

I have looked and have not found any unexpected shorts between the solder pads.

Any debugging advice would be appreciated...
usbtinyisp-top.jpg
usbtinyisp-top.jpg (589.43 KiB) Viewed 684 times
usbtinyisp-bottom.jpg
usbtinyisp-bottom.jpg (685.28 KiB) Viewed 684 times

Re: no green light!

Posted: Mon Jan 23, 2023 2:44 pm
by Franklin97355
OK, try flowing the solder a bit to cover the pads and make sure your cable is a data type. If it still does not work contact [email protected] with a link to this thread and they will get you a new one.

Re: no green light!

Posted: Mon Jan 23, 2023 3:13 pm
by seb_kuzminsky
Thanks for the suggestions!

Both of the USB cables I've been testing with work fine with other "data" devices: when I connect either cable to a hub with a keyboard plugged in, the keyboard works.

I'll try heating up the sparse-looking solder joints and adding a bit more solder, and see if that changes anything.

Re: no green light!

Posted: Mon Jan 23, 2023 3:35 pm
by seb_kuzminsky
I reflowed the suspicious-looking solder joints, and washed the bottom with IPA.

The board behaves just the same: no green LED, and no new USB device shows up when I plug it in.

I'll try emailing support.
usbtinyisp-bottom-try2.jpg
usbtinyisp-bottom-try2.jpg (904.76 KiB) Viewed 673 times