Page 1 of 2

PowerBoost 1000 whine/noise vs. ADC

Posted: Sun Jan 11, 2015 4:09 pm
by benguild
The PowerBoost 1000 is a neat little board but it's producing an audible whine at about 8700Hz for me. (That's what I hear physically from the board) — I've tried a couple different power sources but it always seems to be there.

Unfortunately I don't have a scope here to check the circuit's resulting noise, but I wanted to reach out a few days in advance of having access to one to see if anyone's solved this issue in a clever way. I saw this thread regarding a similar issue, but wasn't sure if a solution was ever made known: viewtopic.php?f=19&t=58065

===============

Scenario: I'm trying to use the ADC on an Arduino Micro to measure a very limited signal source and the noise is showing up there as well. Even without anything attached to the analog input, it's showing variation when powered by the PowerBoost.

Because the signal source is so limited, I've tried pumping it through an amplifier circuit and that works great when the power supply is clean, but with the PowerBoost it's also amplifying the noise and polluting the signal as a result.

I've tried adding caps in various places to smooth the supply as well as RC filters on the input to the amp to try and kill the noise, but haven't had any luck so far. Any tips or ideas on how to work with the PowerBoost 1000? TIA

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Mon Jan 12, 2015 2:53 am
by adafruit_support_mike
The whine is probably microscopic flexing in the inductor or the SMT capacitors. It's something that happens in any circuit oscillating at audio frequencies and carrying enough current, and there isn't any way to prevent it.

WRT cleaning up your supply rails, get about four 1000uF capacitors and connect one leg of each to GND. Connect their high ends with 100mH inductors (which aren't too expensive), and run your power through that. Assuming four caps and three inductors, it's a 7th-order low-pass filter with a corner frequency around 50Hz, so noise in the kilohertz range should be practically nonexistent.

If you really want to go nuts, you can drive the low end of the last cap with an op amp to make a compensating current source:
filter.jpg
filter.jpg (17.3 KiB) Viewed 1168 times
The amp's positive input holds a highly filtered copy of the voltage at the center of the 10k-10k divider, and the feedback is set up for 2:1 inverting gain. Any spikes or dips on the supply rail will appear at the op amp's negative input but not its positive input, so the amp's output will force the cap up or down to compensate for them.

The amount of current the cap can push into the supply rail is limited by the op amp's output current. That will probably be in the 25-50mA range for most inexpensive op amps, but you can get a high-power amp or hook up a buffer if you want more power. Hopefully you won't need anything that drastic though. The LC filter should keep things pretty quiet.

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Mon Jan 12, 2015 3:23 am
by benguild
Hmm, so you're saying 4x 1000µF caps to ground, with 3x 100mH inductors between them? I'll have to give that a try!

The OpAmp compensating circuit seems cool, I'll also have to try that out on a breadboard here because I'm curious to measure the difference. Would it matter if you powered the IC with the pre-filtered rails, or the same filtered supply that it's trying to compensate for?

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Mon Jan 12, 2015 4:49 am
by benguild
Actually can I ask you about the inductors.... Given that the current rating for the PowerBoost is 1000mA+, what does the rating for each inductor need to be in this case? I mean, the Arduino Micro uses much less I'm sure.

Also, shielded vs. unshielded? They're going to be in close proximity but not touching.

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Tue Jan 13, 2015 5:04 pm
by adafruit2
the inductor on the PB1000 is a 4A shielded inductor

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Wed Jan 14, 2015 1:03 am
by adafruit_support_mike
benguild wrote:Would it matter if you powered the IC with the pre-filtered rails, or the same filtered supply that it's trying to compensate for?
Taking the op amp's power from the rail it's compensating is fine, and usually preferred.

The only reason not to do it is the risk of creating an unwanted feedback loop from the output to the supply rails, to components inside the amp, and back to the output. In most commercial op amps the PSRR (Power Supply Rejection Ratio) is so large that any feedback would be a vanishingly small term in the worst possible case.

The reason *to* do it is the same as using a smooth supply rail for any op amp: even if the PSRR is good, some small fraction of rail noise still gets through. Using the cleanest available rail gives you the best possible output.

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Thu Jan 15, 2015 9:41 pm
by benguild
So I had this moment of silliness today when I was assembling the circuit where I realized I only had 1000µF polarized caps. Needless to say, the Micro didn't power up like that.
circuit_beforepolarflip.jpg
circuit_beforepolarflip.jpg (640.42 KiB) Viewed 1124 times
However, I did after this try reversing two of the caps in parallel with two of the others (to create "non-polarized" caps) around only a single inductor, and the Micro just strobed without powering up. I'm not sure if there's enough juice coming out of the PowerBoost 1000 when it's just hooked up to batteries to get through all of those huge components.

I was planning to order some non-polarized caps soon but I wanted to ask... I did have the chance to hook the PowerBoost 1000 up to the scope earlier today and measured the attached (below) noise. However, I've also ordered the PowerBoost 500 since then, as that should produce more than enough juice for this and is a smaller profile board for my project. The key here is physical size, but these caps even at a low voltage are physically pretty huge.
noise.JPG
noise.JPG (399.18 KiB) Viewed 1124 times
Is the 500 going to put out different noise on a different Hz given the different IC and different schematic, or do you think it'll be less noise, or mostly the same? Any recommendations based on these added details? I can order the other caps to here in a minute, but I'm not sure if it's going to work form factor wise since those are huge caps. Just trying to get it to work at all at the moment, though. — Really appreciate the thoughts so far, though. Thanks in advance.

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Fri Jan 16, 2015 4:51 am
by adafruit_support_mike
Hmm.. I didn't think about inrush current. Having to charge a few thousand microfarads of capacitance all at once would present a pretty big current load.

Honestly, the inductors are doing most of the work. If you drop the capacitors to 10uF, the cutoff frequency will only rise to about 300Hz. It goes on a root-of-10 progression, so every time you cut the capacitance to 1/10th its previous value, the corner frequency goes up by a factor of 3.16.

A 7th-order filter is pretty aggressive, so it's safe to move the corner frequency closer to the noise frequency. Attenuation is a bit more than 99% at double the corner frequency (the octave). A 318Hz filter using 10uF caps will attenuate about 99.7% of noise at 1kHz. Dropping the caps to 1uF would take the corner frequency up to about 1kHz, and attenuation would be beyond 99.99% at 4kHz.

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Fri Jan 16, 2015 10:41 pm
by benguild
I tried dropping the caps all the way to 0.1µF without luck. Board might boot but the power light strobes at a higher freq.

In the meantime, the PowerBoost 500 showed up and is less noisy but still too noisy. Any ideas?

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Sat Jan 17, 2015 12:18 am
by adafruit_support_mike
I'll have to build a version and poke around with my own scope.

In the meantime, how much current does your circuit actually use, and how much tolerance do you have on the ouput value of 5v?

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Sat Jan 17, 2015 12:24 am
by benguild
So, here's the thing.
I have a 3.3V source, and it puts out like ~100mA. All of the components use 3.3V except the Arduino Micro, which is why I have to ramp up to 5V and was playing with the PowerBoost ICs.

I had an Arduino Fio but the clockspeed was too slow. It did run on 3.3V though and everything worked fine. Just trying to figure out the missing pieces here really.

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Sat Jan 17, 2015 3:20 am
by benguild
Hey great news—
I messed around with the PowerBoost 500 and some different caps and I was able to get it working *and* quiet! I honestly couldn't be more thrilled right now.

Hooray!

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Mon Jan 19, 2015 1:19 am
by adafruit_support_mike
Glad to hear it!

There's much to be said for just trying different components and arrangements. ;-)

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Fri Feb 20, 2015 5:39 am
by BillMav
Hi, I have Powerboost 500 which is producing the high pitched noise. Can you post the setup of the working filter?

Re: PowerBoost 1000 whine/noise vs. ADC

Posted: Mon Apr 20, 2015 12:11 pm
by ii
I think the noise should be listed in the product listing fore these:
http://forums.adafruit.com/viewtopic.php?f=22&p=366793
and suggested work arounds from adafruit.
I'm getting the same thing, and the pitch varies based on load.
I had a 500 and it had less noise... may need to switch back to them.